Degraded Funnel API performance causing longer loading times on 30% of funnels

Incident Report for FunnelFox

Postmortem

Date: March 7, 2026
Duration: ~25 minutes (13:45–14:10 CET)
Impact: ~30% of funnels experienced slower navigation between screen, while syncing with the Funnel API

What happened

On March 7 at 13:45 CET, about 30% of funnel pages were loading slower.
The issue lasted approximately 25 minutes and was fully resolved by 14:10 CET. Our CDN cache continued serving most funnels normally, which reduced the visible impact.

Root cause

A spike in internal database queries on our read replica created replication lag between the replica and the primary database.
While lagging, the replica served outdated data for some funnels — and those stale responses got cached by our CDN, extending the delay beyond the lag itself.

How we fixed it

We switched funnel traffic from the lagging replica to the primary database, which restored availability immediately. We then purged the cached empty responses. We will conduct an internal investigation how to avoid such incidents in the future.

Posted Mar 07, 2026 - 14:31 UTC

Resolved

This incident has been resolved.
Posted Mar 05, 2026 - 14:15 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 05, 2026 - 14:07 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 05, 2026 - 12:45 UTC
This incident affected: Funnel API.